1. Bicom Systems
  2. Solution home
  3. SERVERware
  4. HOWTOs

SERVERware 3 and 4 Network setup

TABLE OF CONTENTS

Introduction

This document describes the example network design for SERVERware  based on two approaches. First approach describes SERVERware network which doesn’t support redundancy on network level. Second approach is the network design with redundancy on network level, which will allow High Availability of services.

To achieve High Availability which will provide Fault Tolerant Services with minimum to none service disturbance, network design planning has to be based on redundancy on all levels. This means that all important network components have to be redundant.

This document will describe the switching level, up to the second network layer. Routing level depends on global network design and can be different from case to case.

Network design is based on Cisco WS-C3750G series switches. This is a layer 3 switch which supports all protocols and mechanisms required for redundancy. Cisco WS-C3750G switch is able to provide the following features:

  •  32-Gbps switching fabric
  •  Stack-forwarding rate of 38.7 mpps for 64-byte packets
  •  Forwarding rate: 6.5 - 38.7 mpps depends of model

Following switch features will be used to achieve network redundancy:

  •  Cisco CrossStack UplinkFast (CSUF) technology provides increased redundancy and network resiliency through fast spanning-tree convergence (less than 2 seconds) across a switch stack with Cisco StackWise technology.
  •  1:N master redundancy allows each stack member to serve as a master, providing the highest reliability for forwarding.
  •  Cross-Stack EtherChannel provides the ability to configure Cisco EtherChannel technology across different members of the stack for high resiliency.
  •  IEEE 802.1w Rapid Spanning Tree Protocol (RSTP) provides rapid spanning-tree convergence independent of spanning-tree timers and also offers the benefit of distributed processing.
  •  Stacked units behave as a single spanning-tree node.
  •  Per-VLAN Rapid Spanning Tree (PVRST+) allows rapid spanning-tree reconvergence on a per-VLAN spanning-tree basis, without requiring the implementation of spanning-tree instances.
  •  Bandwidth aggregation up to 16 Gbps through 10 Gigabit EtherChannel technology, 8 Gbps through Gigabit EtherChannel technology, and up to 800 Mbps through Fast EtherChannel technology enhances fault tolerance and offers higher-speed aggregated bandwidth between switches and to routers and individual servers. 



SERVERware  non redundant network design

sw3-2-network-setup1.jpg

Above diagram shows typical SERVERware   configuration.

System is built around storage hosts, processing hosts and backup host. Two storage hosts are configured to work in mirror, and provide storage for processing hosts over SAN (Storage Array Network). Processing hosts locally run VPSes provided over storage network. VPSes use WAN network to provide services to customer.

Backup host provides disk space for backup of VPSes. Backup hosts use storage network to transfer data from storage hosts to local backup disk space. Because of the nature of storage traffic we have to separate SAN traffic from other traffic on network. In case that we have a lot of processing hosts, the best solution is to use dedicated network switch which will serve network traffic.

In reality, we will probably use the same switch for SAN and all other traffic. In that case we have to separate traffic using VLAN concept. So for SAN traffic we will create SAN VLAN. Other traffic can be kept in default native VLAN. Optionally we can create VLANs for voice traffic and prioritize that traffic.

Next schematic diagram shows SERVERware  network with one Cisco switch (no network redundancy):

network-setup-cisco3750.jpg

To separate SAN traffic from other traffic on network, we can use VLANs and configure all ports which belongs to SAN network to be members of SAN VLAN.

Here is an example of Cisco configuration which shows how to configure VLANs on ports:

        ...
    interface GigabitEthernet0/0/1
    switchport access vlan 20
    switchport mode access
    !
    interface Vlan20
    description “SAN VLAN”
    no ip address
    ...

SERVERware  - network redundancy

SERVERware  network design with redundancy on network level is based on two network switches which are connected and configured to work in stack.

Schematic diagram of SERVERware network redundancy  is shown on following picture:

network-setup-cisco3750-redundancy.jpg

As can be seen, network in redundancy design is based on two Cisco WS-3750G switches. Switches are connected in stack using appropriate stacking cables. WS-3750G stacking bus supports 32-Gbps. Since we have two switches, hosts have to be connected to both of them. This means that for every connection (SAN, WAN), host must have two ethernet interfaces connected to both switches. This network design allows redundancy on a network level. In case that one switch fails, other switch will take over network traffic.

Cisco switches support EtherChannel over Switch Stacks which is necessary and without it network redundancy will not work.

To separate SAN traffic in redundant network design, we will need to configure appropriate VLANs. Here is an example of Cisco switch configuration with network redundancy and VLANs configured to separate SAN traffic:

interface Port-channel5
 switchport access vlan 20
 switchport mode access
!
interface Port-channel6
 switchport access vlan 20
 switchport mode access
!
interface Port-channel7
 switchport access vlan 20
 switchport mode access
!
interface Port-channel8
 switchport access vlan 20
 switchport mode access
!
…
interface GigabitEthernet1/0/25
 description Controller 1 SAN NIC
 switchport access vlan 20
 switchport mode access
 channel-group 5 mode active
 spanning-tree portfast
!
interface GigabitEthernet1/0/26
 description Controller 2 SAN NIC 
 switchport access vlan 20
 switchport mode access
 channel-group 6 mode active
 spanning-tree portfast
!
interface GigabitEthernet1/0/27
 description Backup SAN NIC
 switchport access vlan 20
 switchport mode access
 channel-group 7 mode active
 spanning-tree portfast
!
interface GigabitEthernet1/0/28
 description Proco SAN NIC
 switchport access vlan 20
 switchport mode access
 channel-group 8 mode active
 spanning-tree portfast
!
…
interface GigabitEthernet2/0/25
 description Controller 1 SAN NIC down left
 switchport access vlan 20
 switchport mode access
 channel-group 5 mode active
 spanning-tree portfast
!
interface GigabitEthernet2/0/26
 description Controller 2 SAN NIC down left
 switchport access vlan 20
 switchport mode access
 channel-group 6 mode active
 spanning-tree portfast
!
interface GigabitEthernet2/0/27
 description Backup SAN NIC down left
 switchport access vlan 20
 switchport mode access
 channel-group 7 mode active
 spanning-tree portfast
!
interface GigabitEthernet2/0/28
 description Proco SAN NIC down left
 switchport access vlan 20
 switchport mode access
 channel-group 8 mode active
 spanning-tree portfast
!
interface Vlan20
 description "SAN VLAN”
 no ip address
!

In this example, two SAN ethernet interfaces of primary controller are connected to switch 1 gigabit port 25, and switch 2 gigabit port 25. These two ports on switch 1 and switch 2 form the etherchannel port Port-channel5. On this etherchannel, port is configured on VLAN 20 which is VLAN for SAN network. Secondary controller is connected to switch 1 gigabit port 26 and switch 2 gigabit port 26. These two ports of switch 1 and switch 2 form the etherchannel port Port-channel6. On this etherchannel, port is configured on VLAN 20 which is VLAN for SAN network. Similar is done for backup and processing hosts network configuration. This is a procedure to configure redundancy on network level.