This problem should only happen on storage hosts but in case of issues occur on processing host procedure is the same.
In case SW3 Host gets stuck in Maintenance mode first try to restart sw connector.
/etc/init.d/sw-connector restart
In case this does not resolve the issue, and restart returns error below, you will have to kill sw-connector process:
* Stoping SERVERware Connector ... * Stopping memcached ... * Stoping sw-connector ... * start-stop-daemon: 1 process refused to stop * ERROR: sw-connector failed to stop
ps -fax | grep connector 41122 ? Ss 0:00 \_ sw-connector: SERVERware Controller 41123 ? Sl 89:27 | \_ sw-connector: worker process 65122 pts/1 S+ 0:00 | \_ grep --colour=auto connector 33210 ? Ss 0:00 sw-connector: SERVERware Host 61949 ? Z 0:00 \_ [sw-connector] <defunct> 61922 ? Ssl 68:15 /opt/sw-connector/bin/swhspare -daemon
Processes marked in bold have to be killed, use kill -9 [PID] command to do it.
In our example this would be:
kill -9 61949 kill -9 33210
Start sw-connector:
/etc/init.d/sw-connector start